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Introduction
HDMI has four differential high-speed lanes. Three lanes are used for data (D0, D1, 
D2) and one lane is used for the clock (Ck).

Performing the electrical measurements to validate the HDMI interface requires 
specific connections to the oscilloscope. The test regimen for both HDMI 1.4 and 
HDMI 2.0 can be divided into two groups of measurement types: single-ended 
measurements and differential measurements. Data eye and data jitter 
measurements require the HDMI clock at the same time.

The critical measurements in HDMI 2.0 (data eye, data jitter, and clock jitter) 
require a complex channel model that implies a single-ended connection to make 
the required differential measurements. Although various approaches are available 
for completing the full test regimen, the most convenient approach is to use 
single-ended connections to the scope whether using differential probes or the 
termination adapters (N7010A). This guide addresses not only the convenience of 
using single-ended connections but also the time-saving switch matrix construct 
that enables one connection setup and no further reconnection.

While there is flexibility in the connections offered, Keysight has selected the HDMI 
clock lane to drive channels 1 and 3 (Ck+ to channel 1 and Ck- to channel 3), by 
default. The data lanes are routed to channels 2 and 4 (D+ to channel 2 and D- to 
channel 4). When connections are made this way, the test selection can be:

• all differential clock tests

• all single-ended clock tests

• all differential tests of the connected data lane

• all single-ended tests of the connected data lane

Testing another data lane requires reconnection of channels 2 and 4, or a switch 
matrix construct. If a switch box is used it must be compensated for in magnitude 
(loss) and in phase (skew). In all cases, it may be required that the untested data 
lanes be terminated. All of these connection requirements are addressed in this 
guide.

In This Guide
This guide describes how you can use the BitifEye BIT-2100 switch, along with the 
Keysight N5399C HDMI Electrical Performance Validation and Compliance 
software, N7010A active termination adapters, and N2809A PrecisionProbe kit, to 
perform sequential testing of all data lanes, one at a time, automatically. 

Four main procedures are required:

• Perform DC and skew calibrations on the probe adapters.

• Configure the BIT-2100 switch.

• Set up the switch in the N5399C HDMI application.
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• Use PrecisionProbe / PrecisionCable for AC response correction for signal 
paths.

For More Information

• Find the latest version of the BitifEye BIT-2100 Series Switch System User 
Manual at http://www.bitifeye.com/.

• Find the Keysight N5399C/N5399D HDMI Test Compliance Application Online 
Help at www.keysight.com/find/N5399C.
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1 Configure, Set Up, Calibrate

Equipment required

Description Critical 
specifications

Recommended model/part number

Keysight Infiniium oscilloscope ≥ 16 GHz 
bandwidth

Infiniium 90000 X-Series, Q-Series, 
V-Series, or Z-Series

Active termination adapter probes (4 
required)

N7010A

HDMI 2.0 TPA fixture BitifEye BIT-1010-0200-0 HDMI Type A 
Source Test Plug Adapter Kit

Wilder Technologies 
HDMIA2-TPA-12P or HDMIA2-TPA-6P

Phase-matched SMA cables (2 sets 
required)

25 ps 15443A

Short, semi-rigid or flexible coaxial 
cables for routing on switch box

Rosenberger 24/14 023A 
L99-001-000

SMA (f)-(f) or APC 3.5 mm adapters (3 
pairs)

3.5 mm

HDMI termination module or connecting 
terminations*

50 Ohm to 3.3 V Wilder HDMI Termination Module 
model HDMI-TPA-T

Torque wrench 5/16”, 5 in-lbs 8710-1582

PrecisionProbe software and cable 
calibration kit

N2809A

BitifEye BIT-2100 Series switch module: 
one 6x SPDT module and two 1x SP4T or 
two 1x SP6T modules

BitifEye BIT-2162A (6x SPDT) 
BitifEye BIT-2114A (1x SP4T) 
BitifEye BIT-2116A (1x SP6T)

Phase-matched cables for data lanes to 
switches (3 sets, optional)

15443A

* Terminations can be done in several ways. The examples in this guide use a Wilder HDMI-TPA-T with a USB 
source, but you can also use N5380B probe heads with center pin to 3.3 volt supply. You can also use bias tees 
and a separate 3.3 V supply. The Wilder solution is the simplest and lowest cost.

Connecting terminations may be optional if:

—Your device will work with a subset of the TMDS lanes connected. Most HDMI silicon has been shown to operate 
with minimal terminations.

—You determine that your results are independent (that is, you do not see cross-talk degradation).
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Performing a DC Calibration on N7010A Adapters

If the N7010A adapters have not yet had DC attenuation/offset and skew 
calibrations for the specific channels they are connected to, we recommend 
performing those calibrations now rather than interrupting the AC Response 
calibration procedure later.

1 Connect an N7010A adapter to each channel on the oscilloscope.

2 In the Infiniium application, open the Channel dialog box and select Probe Cal..., 
or click Setup > Probe Calibration....

3 Click Start Atten/Offset Cal... and follow the instructions for connecting an SMA 
cable from the channel to Cal Out and running the calibration.

4 Click Start Skew Cal... and follow the instructions that appear.

5 Repeat step 3 and step 4 for each channel until all probe adapters have 
completed the DC and skew cals.

y

Figure 1 No DC or Skew cals performed yet

Figure 2 DC and Skew cals completed
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Configuring the BIT-2100 Switch

1 Make sure the BIT-2100 switch is loaded with two SP4T (or SP6T) switch 
modules and one 6x SPDT module. The SP4T (or SP6T) modules belong in slots 
3 and 5, and the 6x SPDT module belongs in slot 4. See Figure 3.

2 Refer to Figure 4 on page 9 to connect the cables on the BitifEye switch for 
HDMI testing as follows:

• Using one of the 15443A SMA matched cable sets and a pair of (f)-(f) SMA/APC 
3.5 mm adapters, route the center SMA of module 3 to channel 2 on the 
oscilloscope, and route the center SMA of module 5 to channel 4 (through the 
N7010A termination adapters).

• Use the other matched cable set and two pairs of (f)-(f) SMA/APC 3.5 mm 
adapters to route from the clock signal (Ck+ and Ck-) to channels 1 and 3 of the 
oscilloscope (through the N7010A termination adapters) directly from the 
HDMI TPA.

• Route the SMA cable breakouts from the HDMI TPA of the data lanes to the 
center (common) of the six SPDT switches.

• Route the bottom SMA, port 2, of these switches to the HDMI termination.

• Route the top SMA, port 1, of these switches to the SP4T switches. Route all of 
the D+ signals from the HDMI device under test to module 3 through the SP4T 
switches, and route the D- signals to module 5 as shown in Figure 4.

Figure 3 BitifEye BIT-2100 switch with two SP4T modules and one 6x SPDT module

NOTE For help with this step, refer to the BIT-2100 Series Switch System User Manual chapter on 
mounting modules and setting addresses for each module.
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Figure 4 Cable connections on the BitifEye BIT-2100 switch for HDMI testing

D2+D1+D0+D2-D1-D0-

From HDMI TPA

To channel 4

To channel 2

USB power Clk-

To channel 3 To channel 1

To HDMI Termination

Clk+
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Setting Up the Switch in the N5399C HDMI Software

The N5399C HDMI software running on an Infiniium oscilloscope needs a 
connection to the switch in order to control it. Three types of connections are 
possible:

• USB cable between switch and oscilloscope

• LAN (both oscilloscope and switch connected to LAN)

• LAN cable between switch and oscilloscope

This chapter assumes you will use the first type, a USB cable connection. The LAN 
connection types are described in Appendix A, “Using a LAN Connection”.

Now that the BIT-2100 switch is configured, you need to configure the testing 
environment for the HDMI software.
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Configure the switching paths

You can configure the switching paths either automatically or manually. If you 
cabled the switches as shown in Figure 4 on page 9, you can configure the paths 
automatically as described here. If you cabled the switches differently than shown 
in Figure 4, you need to manually set up the switch matrix to match the cabling 
(see Appendix B, “Configuring Paths Manually”).

1 Connect the USB cable between the switch and the oscilloscope.

2 Start the HDMI application from the Infiniium application (Analyze > Automated 
Test Apps > N5399C/N5399D HDMI Test App).

3 Drag the HDMI Test window to the bottom of your screen, leaving the menu bar 
accessible.

4 Click Tools > Switch Matrix.... 

5 In the Configure Switch Matrix Settings dialog box, select On to make the 
grayed-out sections active.

6 Select Automatically select drivers and paths. 

7 Select the BitifEye BIT2100 model and click Connect.... The Connect To BitifEye 
BIT2100 dialog box appears.

8 Select the Select from Keysight Connection Expert button and click the SICL 
address that shows a USB device.

Figure 5 Connecting to the switch matrix
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9 Click OK.

10 Click Next>> to go to the Signal Paths tab.

Figure 6 Selecting the USB device
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Using PrecisionProbe for AC Response Correction for Signal Paths

Now that the switch is configured and is controllable, you need to calibrate each of 
the six paths. 

PrecisionCable calibration will compensate the path loss vs. the frequency of each 
path, plus the skew, so it is critical to the operation of the switch. 

1 Open the Channel 2 dialog box.

2 Click Setup... in the PrecisionProbe/PrecisionCable field. The Channel 2 
PrecisionProbe/PrecisionCable dialog box appears.

Figure 7 Infiniium Channel dialog box

Figure 8 Starting PrecisionCable
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3 Click Start PrecisionCable AC Calibration to start the PrecisionCable Wizard.

4 Read the PrecisionCable Wizard initial screen and click Next > to open the 
Connect Trigger step of the wizard. 

5 In the wizard’s Connect Trigger screen (Figure 9), follow the instructions to 
connect a cable from Cal Out to channel 3. You will need to temporarily remove 
the N7010A adapter. Click Next > to advance to the Connect Through step.

6 In the Connect Through screen of the wizard, the example picture is not correct 
for your test scenario. You need to connect only one cable (not two) directly 
into channel 2 (not channel 1) from Aux Out. 

Figure 9 PrecisionCable Wizard — Connect Trigger
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7 After making the correct connection, click Measure and wait for the calibration 
to complete. 

8 Click Next > to advance to the Connect Cable step.

Figure 10 PrecisionCable — Connect Through screen
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1 Configure, Set Up, Calibrate

9 The example picture in the Connect Cable screen in Figure 11 also does not 
reflect your test scenario. It shows a purple cable that represents your switch 
matrix path, but it does not have the N7010A in place. You must put the 
N7010A adapter back onto channel 2.

10 Connect the cable from Aux Out to the common of the particular SPDT switch 
of the path you are calibrating. The example picture in Figure 12 uses D0+.

11 Connect the cable coming out of the SP4T common to the N7010A adapter on 
channel 2, as shown in Figure 12. This second measurement will determine the 
difference between the reference measurement and the one with the N7010A 
adapter and the path. This difference provides you with a total, absolute 
correction. 

Figure 11 PrecisionCable— Connect Cable
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12 Click the buttons in the switch matrix you saved to change the currently set 
switch path. See Figure 13.

Figure 12 Channel 2 and Aux Out connections

Figure 13 Updated switch matrix

Connect to adapter on channel 2

Connect to Aux Out
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1 Configure, Set Up, Calibrate

13 Click Measure in the wizard, then click Next > when the measurement is 
complete.

14 When the process is complete, you will be prompted to enter a calibration file 
name. Choose a name that is easily identifiable, such as D0_plus. 

15 Click Next > and Cal Another Cable until you have calibrated the other two paths 
of D+ data lanes. Use consistent naming, such as D1_plus and D2_plus. 

Remember that you need to move the physical cables and update the switch 
matrix for each path, just as you did for the D0_plus path. You will connect Aux 
Out to switch 2 common for D1+, and Aux Out to switch 3 common for D2+.

16 When you are done calibrating all three paths, click Finish.

17 Review the calibration files for quality. 

As you review your own results, note a few things in the screen in Figure 15:

• The response should decrease monotonically. For example, a sharp narrow 
band that changes quickly indicates a cable connection problem. Use a 
torque wrench to tighten the connection.

• Notice the 6 dB of loss at 15 GHz. This loss would be a benchmark for all 
channels. The greater the loss to compensate for, the more susceptible to 
noise your measurements will be.

• Setting the bandwidth to 16 GHz makes a flat result up to about 14 GHz.

Figure 14 Assigning a cal file name
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18 Repeat this procedure on channel 4 for the D- lanes. Assign identifiable names 
such as D0_minus, D1_minus, and D2_minus.

Remember, as with the D+ lanes, you need to move the cables and update the 
switch matrix for each path.

19 Calibrate the cables being used by the clock lines by repeating path calibration 
for channels 1 and 3. Use clear names such as Clk_plus and Clk_minus.

a Start the PrecisionProbe wizard.

b At the Connect Through screen, connect AuxOut directly into channel 1 
(Figure 16).

Figure 15 PrecisionCable response
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1 Configure, Set Up, Calibrate

c At the Connect Cable screen, connect the Clk+ cable into channel 1, through 
the N7010A adapter.

d Complete the path calibration steps for channels 1 and 3.

Figure 16 Connecting channel 1 and Aux Out for the clock

Figure 17 Connecting the Clk+ cable into channel 1, using the N7010A adapter
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When all calibration is complete, your mapping will be:

• Clk_plus in channel 1

• D0_plus, D1_plus, and D2_plus in channel 2

• Clk_minus in channel 3

• D0_minus, D1_minus, and D2_minus in channel 4

Assigning cal files to the paths

Next, you need to assign these calibration files to the paths in the HDMI 
application:

1 In the HDMI software application, choose Tools > Switch Matrix... and click the 
Response Correction tab.

Figure 18 Response correction calibration
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1 Configure, Set Up, Calibrate

2 For each row, select the PrecisionProbe correction mode. A new dialog box 
appears:

3 Select Include Cable Delay (Figure 19) to minimize skew on each line, and specify 
16 GHz of bandwidth because the HDMI application sets the bandwidth of the 
measurement to 13 GHz. You do not want the combination of this response and 
the oscilloscope response to produce a lower bandwidth.

4 Click OK. Notice that the settings appear in the response column in the table 
under the Response Correction tab.

Figure 19 Settings for use of the PrecisionCable calibration file

NOTE If the Include Cable Delay and Specify Bandwidth controls are grayed out, you may need to 
clear the On check box (Figure 19) and re-select it.
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5 Use the Configure PrecisionProbe / PrecisionCable dialog box (Tools > 
PrecisionProbe/PrecisionCable...) to enter clock cable information for channels 1 
and 3. Select Channels 1 and 3, select the Clk_plus and Clk_minus files 
respectively, and make the cable delay and bandwidth selections as you did in 
step 3.

Figure 20 Response correction calibration file assignments
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Running Tests to Verify the Setup

Now that you have set up the switch, you should run some tests to ensure the 
setup is working properly.

Configure the switching operation

1 Click Analyze > Automated Test Apps > N5399C /N5399D HDMI Test App to start the 
N5399C HDMI compliance application.

Figure 21 HDMI Test setup screen
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2 Click the Connection Setup box to open the Test Connection Setup dialog box.

3 Select the Test Fixture Type (Wilder HDMI TPA-P in Figure 22) and the Probe Type 
(N7010A).

If you are using the FlexEDID or QD 980 for the EDID emulation, select the 
Enable Automation check box and select the driver. 

You will need to set up the switch matrix modules in the lower left area of the 
dialog box if you enable automation.

4 Close the Test Connection Setup dialog box to return to the HDMI Test dialog 
box.

Figure 22 Test Connection Setup dialog box
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As an example, Figure 23 shows HDMI set-up selections for fall time of the clock, 
D0, D1, and D2.

Figure 23 HDMI Test—Set Up tab
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The Connect tab of the HDMI Test would look like the one in Figure 24.

After you select the check box at the bottom of this screen to show you have 
completed these instructions, click Run Tests. 

Figure 24 HDMI Test—Connect tab



28 HDMI Compliance Testing with the BitifEye BIT-2100 Switch and Keysight N7010A Adapters
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When the tests are complete, click the Html Report tab to see the overall result 
(Figure 25).

Figure 25 HDMI Test—Html Report tab
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N5399C HDMI Software and  BitifEye BIT-2100 Switch
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A Using a LAN Connection

If you prefer to use a LAN connection rather than a USB to connect the 
oscilloscope to the switch, you can either connect both the oscilloscope and the 
switch to the LAN, as described in this appendix, or connect a LAN cable between 
the switch and the oscilloscope.

Oscilloscope and switch both connected to a LAN

1 Assuming the oscilloscope is already connected to the LAN, connect the switch 
to the LAN, press the LXI LAN Reset button on the switch for the oscilloscope to 
re-acquire its IP address, and wait 2 minutes.

2 Click IO > Connection Expert from the bottom right area of your oscilloscope.

3 Locate and click the BIT2100 instrument in the left side of the Instruments tab. 
If you do not see BIT2100 in the list of instruments, go to “Using a USB 
connection to determine the VISA address" on page 30.

4 Take note of the SICL address for later reference.

Figure 26 Keysight IO Libraries Suite

NOTE Figure 27 shows IO Libs version 17.X. If you have an earlier version, the interface will look 
different.
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A Using a LAN Connection
 

Using a USB connection to determine the VISA address

If Connection Expert is unable to locate the switch, which may happen when there 
are too many instruments on a large network, you can use a USB connection to 
find the IP address:

1 Connect the USB cable between the switch and the oscilloscope. You will see 
the VISA address in the Connection Expert:

Figure 27 Using Keysight Connection Expert (Keysight IO Libraries) to find the switch

Figure 28 VISA address
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2 Click Send Commands To This Instrument (Figure 28) to start the Interactive IO 
utility.

3 In the Command field, enter the :NET:IP? command and click Send & Read to find 
the IP address of the switch. Use the right-click menu to copy the address.

4 Close the Keysight Interactive IO window.

5 In the Keysight Connection Expert, click the Manual Configuration tab and 
paste the copied IP address into the Hostname or IP address field.

Figure 29 Finding the IP address using USB cable and Keysight IO Libraries
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A Using a LAN Connection
 

6 Click Test This VISA Address.

C

7 Click Accept.

Figure 30 Copy the IP address into the Hostname or IP Address field

Figure 31 Test This VISA Address
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B Configuring Paths Manually

If you want to connect your cables in a different way than described in this guide, 
follow these steps to manually set up the switch matrix.

1 Connect the USB cable between the switch and the oscilloscope.

2 Start the HDMI application from the Infiniium application (Analyze > Automated 
Test Apps > N5399C/N5399D HDMI Test App).

3 Drag the HDMI Test window to the bottom of your screen, leaving the menu bar 
accessible.

4 Click Tools > Switch Matrix.... 

5 Select On to make the grayed-out sections active.

6 Select Manually perform these tasks.

7 Select the model of the switch (BitifEye BIT2100).

8 Click Add.

9 Click Connect....

10 Select the Signal Paths tab, then use Figure 32 as an example when setting up 
your switch matrix. Before you begin setting the switches, read these helpful 
tips:

• Start with module 4, putting the HDMI inputs into the switch matrix.

• Click the blue text in and out to toggle between them. For example, assume 
you want module 4 to be configured as a set of 1 in and 2 out, though it 
defaults as 2 in and 1 out.

• Because the switches are active at this point, you can click any of the boxes 
in the middle (Switch) column to control the switch.

• When you have a valid path to channel 2 or channel 4, the box will appear as 
green for channel 2 and red for channel 4.
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B Configuring Paths Manually
 

11 Click Save... at the bottom of the dialog box to save your configuration for future 
use. Choose a name that is easy to remember.

12 Close the Configure Switch Matrix Settings dialog box.

Figure 32 Switch definition showing module 3 and part of module 4 configuration

NOTE If your switch settings do not appear when you open the dialog box, click Reload to load the 
saved file.
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